Vetus heat exchanger

Ask an Expert !
Do you have a question about any aspect of YM designed boats?

Moderators: Eventide Owners Group, Piskie, chris s

Billaboard
Posts: 25
Joined: Thu October 5th, 2006, 9:48 pm

Vetus heat exchanger

Postby Billaboard » Sun July 12th, 2009, 4:47 pm

We have a Vetus 2 cylinder inboard based on a Mitsubishi engine that has been and still is running really well, and is a good match to the Wild Duck.

I have been a bit worried about the coolant suddenly changing from green to clear when we lifted in, and yesterday we had the first "shakedown" of the season.

All went well. We lashed the mainsail in place and I've now found the fittings I stupidly left off after repainting the boom, so that's OK. But the engine overheated twice.

I'm asking here in the vague off-chance that someone is a real expert with these engines, so here is the story.

About 12 years ago we had an overheating problem, dismantled the heat exchanger and took it to the nearest Vetus agent for him to look at. I took with me some long, thin drill bits, and it was as well that I did because he dismantled and determined that we should clean out the tiny pipes using my drills. He did this and the engine has, until now been fine. But now I'm worried that the pipes may have a small leak as well as blockage.

He said that there is no manufacturer of similar heat exchangers, and that this particular type was made by a lone Dutchman to fit these engines. When he retired, the replacements required a change of engine design, and the current exchangers are impossible to fit.

So my question, before I make contact with the agent again, is whether anyone knows of a common bodge for these older Vetus engines (incidentally, it was badged something like SMC rather than Vetus, but is identical to the Vetus model of that age). Would, for example, a maker of model steam locomotive boilers be able to repair or replace the tubes in one of these wonderful, craftsman made devices?

I'm feeling too old and decrepit (and poor) to replace the engine!

User avatar
Eventide Owners Group
Posts: 224
Joined: Wed March 1st, 2006, 1:00 pm
Contact:

Re: Vetus heat exchanger

Postby Eventide Owners Group » Tue August 4th, 2009, 4:47 pm

We too have a similar motor, a 3 cylinder Kubuto not a Mitsibushi as yours is, I wonder if the coolant might be contaminated and if so yes there could be a leak, but I bet there are 'o' ring seals on the end of the 'stack' of tubes and if like the Beta marine one, replacing the seals might solve the problem...

I take it the jabsco sea water pump is OK? we had a problem once with one shedding blades and blocking the stack....

The coolant level in the motor will drop I would have though, if there was a leak in the stack...

Just a thought. you could also test to see if the coolant has become salt, assuming you sail in salt water... That would confirm the leak.

sound like you might have to strip the stack down to carefully pressure test each tube, done technically with a thumb and suction applied by mouth!

This spring we gave our motor a good going over, first time in 15 years, and part of that was to run the motor with a hose pipe attached to the inlet seacock from a tank full of water with central heating de scaler in it. the water changed colour, so we must have shifted something from our system!

good luck,
John
Web site Coordinator


Return to “HELP ?”

Who is online

Users browsing this forum: No registered users and 1 guest